
Computer Automotive Tuning Systems 

Page 1 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 

Tuner Program Reference Manual 
 

Revision H 
 
 
 
 
 
 
 

 
 

  



Computer Automotive Tuning Systems 

Page 2 

Table of Contents 
Introduction ................................................................................................................................................. 4 
Program Installation .................................................................................................................................... 4 
Minimum PC Requirements ....................................................................................................................... 5 
What You Need To Begin Tuning .............................................................................................................. 5 
ECM Definition Files .................................................................................................................................. 6 

Obtaining An ECM Definition File ........................................................................................................ 6 
Selecting An ECM Definition File ......................................................................................................... 6 
Installing An ECM Definition File ......................................................................................................... 7 
ECM Definition File Version.................................................................................................................. 7 
ECM Definition File Help ...................................................................................................................... 8 
ECM Definition File Password ............................................................................................................... 9 

ECM Calibration Files .............................................................................................................................. 10 
Opening A Calibration File ................................................................................................................... 10 
Saving A Calibration File ..................................................................................................................... 12 

Calibration Tables ..................................................................................................................................... 14 
Switch Type Calibration Table ............................................................................................................. 14 
Constant Type Calibration Table .......................................................................................................... 14 
2D and 3D Calibration Tables .............................................................................................................. 15 
Opening A Calibration Table ................................................................................................................ 16 
Viewing Calibration Table Graphs ....................................................................................................... 17 

Changing 2D Graph Views ............................................................................................................... 19 
Changing 3D Graph Views ............................................................................................................... 21 

Editing Calibration Values ........................................................................................................................ 21 
Editing Switch Type Calibration Table Values .................................................................................... 22 
Editing Constant Type Calibration Table Values ................................................................................. 22 
Selecting 2D and 3D Table Cells .......................................................................................................... 24 
Editing 2D and 3D Table Values .......................................................................................................... 25 

Increment/Decrement ........................................................................................................................ 26 
Add .................................................................................................................................................... 26 
Subtract ............................................................................................................................................. 26 
Fill ..................................................................................................................................................... 27 
Scale .................................................................................................................................................. 27 
Drag Graph Points............................................................................................................................. 27 
Copy and Paste Table Values ........................................................................................................... 28 

Undo / Redo Functions ......................................................................................................................... 30 
Importing Table Values ........................................................................................................................ 31 
Restore Table Values ............................................................................................................................ 32 
Calibration Tools .................................................................................................................................. 33 

Speed Calibration .............................................................................................................................. 33 
VIN Information ............................................................................................................................... 35 
Calibration Notes .............................................................................................................................. 36 
Read PCM ......................................................................................................................................... 36 
Program PCM ................................................................................................................................... 39 

Comparing ECM Calibration Files ........................................................................................................... 41 
Opening A Compare ECM Calibration File ......................................................................................... 42 
Viewing A Calibration Table in Compare Mode .................................................................................. 43 



Computer Automotive Tuning Systems 

Page 3 

Generating Reports ................................................................................................................................... 45 
Printing An ECM Calibration Table ..................................................................................................... 45 
Printing An ECM Calibration Table Graph .......................................................................................... 45 
Print All ECM Calibration Tables ........................................................................................................ 46 
Printer Setup.......................................................................................................................................... 47 
Print All ECM Calibration Tables To A File ........................................................................................ 48 

Default Path .............................................................................................................................................. 49 
Program Options ....................................................................................................................................... 50 
Window Arrangement ............................................................................................................................... 54 
Comments and Problem Reports .............................................................................................................. 55 
Software License, Copyright And Warranty ............................................................................................ 55 
Software Registration................................................................................................................................ 56 
Program Updates ....................................................................................................................................... 56 
Appendix A – Recovering and Reseting the PCM ................................................................................... 58 
Appendix B - PCM Read/Program Communications Errors .................................................................... 59 
Appendix C – Supported ECMs And PCMs............................................................................................. 61 
Appendix D – LT5 ECM Definition Files ................................................................................................ 64 
Appendix E - RT Tuner Instruction Addendum ....................................................................................... 65 

Introduction ........................................................................................................................................... 65 
Background Calibration Updates .......................................................................................................... 65 
Quick Start ............................................................................................................................................ 65 
Program Startup .................................................................................................................................... 66 
Calibration Synchronization ................................................................................................................. 67 
New Tools Menu................................................................................................................................... 67 
New Toolbar Buttons ............................................................................................................................ 68 
New Options ......................................................................................................................................... 68 
Status Bar .............................................................................................................................................. 68 
Real-Time Calibration Changes ............................................................................................................ 69 



Computer Automotive Tuning Systems 

Page 4 

 

Introduction 
The OBDI. Tuner program is a Windows based utility developed to easily make changes to GM 
ECM/PCM engine and transmission control parameters. The program is designed to run on Windows 
XP and later operating systems. 
  
The program provides the ability to change ECM/PCM calibration values without working through tens 
of thousands of binary bytes to determine which are computer instructions, and which are data tables, 
and what engine parameters these data control. You can tune a computer-controlled engine with no 
knowledge about the actual ECM/PCM software.  
 
The C.A.T.S. Tuner program presents all the important tuning parameters in clear easy to understand 
tables that can be directly edited via keyboard and mouse commands. Once you have made the desired 
changes, the program rebuilds a valid ECM/PCM file that can be used to program the ECM/PCM. 
 
A configuration file is required for each unique ECM/PCM. Additional configuration files can be 
installed and accessed via the ECM  pull-down menu. See the C.A.T.S. web page at www.tunercat.com 
for a list of the ECM configuration files currently available. 
 

Program Installation 
To install the Tuner program, download the setup program from the ‘Downloads’ page on the C.A.T.S. 
web site (www.tunercat.com).  
 
Once you have the downloaded the setup program double click on it to begin the installation. To 
complete the installation, follow the on-screen instructions. You may be asked to restart your computer 
after the installation is complete. Once the installation is complete, you can delete the setup file from 
your PC’s desktop. 
 
If you are installing the Tuner program on a PC running Windows 7, 8, 10 or 11 then please install the 
program as follows: 
 
1. Log on to your PC as an administrator.  
 
2. Now double click on the setup program to install the Tuner program and follow the on-screen 
instructions to complete the installation. 
 
3. After completing the installation, set the Tuner program to run in compatibility mode. To do so, right 
click on the Tuner icon on your Desktop, Select 'Properties' from the pop-up menu and then click the 
'Compatibility' tab. On the Compatibility screen check the 'Run this program in compatibility mode for' 
box, select the default Windows XP SP3, check the 'Run as administrator' box, click on the 'Apply' 
button and then click on the 'OK' button. 
 
 
If you purchased the software on a CD ROM you can run the setup program right from the CD. To do 
this place the C.A.T.S. CD into your CD ROM drive and the program should auto start. If it doesn’t, 
navigate to your CD ROM drive and double click on the ‘autorun.exe program to start the installation 
process.  
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If you are installing the Tuner program on a PC running Windows 7, 8, 10 or 11 then after completing 
the installation set the Tuner program to run in compatibility mode. To do so, right click on the Tuner 
icon on your Desktop, Select 'Properties' from the pop-up menu and then click the 'Compatibility' tab. 
On the Compatibility screen click on the 'Run the program in compatibility mode, select the default 
Windows XP SP3, check the 'Run as administrator' box, click on the 'Apply' button and then click on the 
'OK' button. 
 
 

Minimum PC Requirements 
The Tuner program will run on virtually any PC running Windows XP or later. 

 
What You Need To Begin Tuning 
To tune a vehicle, you’ll need the Tuner program and the appropriate ECM Definition File for the 
vehicle you are working on. Go to the ‘ECMs Supported’ page on our web site (www.tunercat.com) for 
a list of the vehicles that are currently supported. 
  
In addition to the above software, you'll also need some additional hardware. For all the ECMs that used 
a removable EPROM to store the calibration information you have two basic options: 
 
Option 1: 
 
Purchase one of our OBD1-Tune-Kits that includes everything you’ll need to tune your vehicle. 
 
Option 2:  
Purchase a standard EPROM programmer and an EPROM eraser. Virtually any EPROM programmer 
will work with the EPROMs used in these ECMs. We recommend the Pocket Programmer from 
Transtronics (https://secure.transtronics.com). It is very reasonably priced and works well. Like the 
programmer, almost any EPROM eraser will work. Transtronics also carries an inexpensive eraser that 
works fine. 
 
In the case if the 1994 – 95 LT1 cars and the 1994 – 95 L32 and L82 V6 cars, the PCMs did not use a 
removable EPROM like the earlier ECMs and you won’t need and EPROM programmer or eraser. 
These PCMs used FLASH memory that is read and programmed over the ALDL diagnostics port. To 
connect your PC to the vehicle for reading and programming the PCM, you’ll need one of our 
USB/ALDL cable sets.  
 
We offer complete tuning kits for these cars as well. For the 1994 – 95 LT1 cars these kits include the 
Tuner program, the $EE ECM Definition File and the ALDL interface cable you need to read and 
reprogram the car's computer. This cable connects you PC to the car's ALDL (diagnostic) connector 
under the dash. Two different ALDL connectors were used in these cars; an OBDI style 12 pin 
connector and an OBDII style 16 pin connector.  
  
There are three different versions of these kits available. Which version you'll need depends on the type 
of ALDL connector in your car: 
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 LT1-Tune-1: This kit includes an OBDI style ALDL interface cable for cars with the OBDI 
style 12 pin ALDL connector. 
 
LT1-Tune-2: This kit includes an OBDII style ALDL interface cable for cars with the OBDII 
style 16 pin ALDL connector. 
 
 LT1-Tune-Y: This kit includes an ALDL interface cable that will work with both types of 
ALDL connectors. 

 
Similarly, the tuning kits for the 1994 – 95 L32 and L82 cars include the Tuner program, the V6 ECM 
Definition File and the ALDL interface cable you need to read and reprogram the car's computer. There 
are three different versions of these kits available as well. Which version you'll need depends on the type 
of ALDL connector in your car: 
  

 V6-Tune-1: This kit includes an OBDI style ALDL interface cable for cars with the OBDI style 
12 pin ALDL connector. 
 
V6-Tune-2: This kit includes an OBDII style ALDL interface cable for cars with the OBDII style 
16 pin ALDL connector. 
 
 V6-Tune-Y: This kit includes an ALDL interface cable that will work with both types of ALDL 
connectors. 

 
 

ECM Definition Files 
The C.A.T.S. Tuner program uses a unique ECM Definition File to define the ECM parameters for each 
unique type of ECM. A wide variety of ECM Definition Files are available. See the C.A.T.S. web page 
at www.tunercat.com for a list of the ECM Definition Files currently available. 
 
To insure proper operation the correct ECM Definition File must be selected before viewing or editing 
an ECM calibration file. 
 
Obtaining An ECM Definition File 
You can also purchase ECM Definition Files on-line from the C.A.T.S. web site at www.tunercat.com. 
 
Selecting An ECM Definition File 
To display a list of all the installed ECM Definition Files, click on the  ECM drop-down menu on the 
main display.  
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To select a definition file, click on the desired file. This will activate the selected definition file and 
close the drop-down list. The definition file currently in use is displayed in the title bar of the main 
screen. 
  
Note: If you only have one ECM Definition File installed, the file will automatically be selected when 
the program starts and the 'ECM' drop-down menu will be disabled. 
 
Installing An ECM Definition File 
To make an ECM Definition File accessible to the C.A.T.S. Tuner Program, simply place the definition 
file  into the C.A.T.S. Tuner Program subdirectory (normally c:\Program Files\CATS\Tuner but may be 
different if you are running a 64-bit version of Windows). 
 
ECM Definition File Version 
C.A.T.S. is continually updating and adding capabilities to the Tuner program. In many cases this 
includes changes to the ECM Definition Files. To keep tack of these changes, each ECM Definition File 
carries a version letter which is advanced with each modification. 
 
To view the version of the ECM definition Files currently being used, select  About  from the  Help  
menu.  

 
 
This will display the about screen which shows various program information including the ECM 
definition File version letter. 
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If you have multiple ECM Definition Files installed, you can view the version of all your definition 
files. To display this report, select  Version Information  form the  Help  menu.  
 

 
 

 
 
To create a hard copy of the version report, click on the  Print  button. 
 
A list of all the current file versions is available on the C.A.T.S. web page. If you need an update to one 
of your ECM Definition Files, please send us an e-mail to request the latest version. 
  
ECM Definition File Help 
If an ECM Definition File help file for the Definition File you are using is installed, you can access the 
Definition File help from the 'Help' menu.  
 
To access the Definition File help, select 'Calibration Help' from the 'Help' menu. 
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This will display the Definition File help screen. 
  

 
 
 Use the navigation keys on the help screen toolbar to move around in the help file. Click on the '+' next 
to the categories in the contents box to expand them. 
 
ECM Definition File Password 
If the ECM Definition File that you have selected has been password protected, the password input 
screen will be displayed. 
  

 
 
To begin using the ECM Definition File enter the correct password and click on the 'OK' button. 
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ECM Calibration Files 
 An ECM calibration file is a binary format file created by reading the EPROM from you vehicles ECM. 
This is accomplished using an appropriate EPROM programming device. To be compatible with the 
C.A.T.S. Tuner Program, the ECM Calibration File, must be saved in binary format with the .BIN 
file extension.  
 
In the case of the 1994 – 95 LT1 FLASH PCM's supported by the $EE ECM Definition File, the 
program will also accept .lt1 format files.   
 
Opening A Calibration File 

To open an ECM Calibration file select 'Open File' from the  File menu or click on the Open File  
button on the tool bar at the top of the screen.  
 

 
 
This will display the 'Open File' dialog box. Select the desired file and click the 'OK' button. 
  

 
 
If you are using the $EE ECM Definition File, the Tuner program can also open .lt1 format files. 
 



Computer Automotive Tuning Systems 

Page 11 

To open an .lt1 format file, click on the drop-down arrow to the right of the 'Files of type' box and select 
lt1 Files (*.lt1) from the drop-down list. 
  

 
 
When you select a calibration file, the program will verify that it is a valid calibration file and that the 
correct ECM Definition File has been selected. If the incorrect configuration file has been selected, the 
following error message will be displayed. If possible, the program will indicate which ECM Definition 
File is required for the selected calibration.    
 

 
 
To open the selected calibration file, note which definition file is indicated and click the 'OK' button. 
Click on the 'ECM' drop-down menu and select the correct ECM Definition File (if installed) and then 
re-open the desired calibration file. 
 
It is relatively common for custom chip manufacturers to change the Program ID when they create a 
new calibration. This will make the Tuner program think it should use a different ECM Definition File. 
If the calibration file is the correct length but a different ECM Definition File is indicated, you will 
receive the following message when you try to open the calibration file: 
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If you believe that you have selected the correct ECM Definition File, you can click on the 'Yes' button 
to continue and the Tuner program will open the selected calibration file. 
 
Note: There are a few ECM Calibrations Files that the program can not distinguish between such as the 
$32 and the  $32B or the $DA2 and $DA3 definition files). In these cases, the program will indicate $32 
or $DA as the correct ECM Definition File and the user will have to make the final decision. 
 
Saving A Calibration File 
To save an ECM Calibration file after editing back to the same file name, select  Save from the  File 

menu or click on the save file button  on the tool bar at the top of the screen.  
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To save the edited calibration file to a different file, select 'Save As' from the 'File' menu.  
 

 
 
This will display the 'Save As' dialog box. Select another file or type in a new file name and click the 
'Save' button. 
  

 
 
If you are using the $EE ECM Definition File, you can also save the edited file in .lt1 format instead of 
binary. 
  
To save the file in .lt1 format, click on the drop-down arrow to the right of the 'Files of type' box and 
select lt1 Files (*.lt1) from the drop-down list. Type in a file name and click 'Save'. 
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Before saving the ECM calibration file, the program recalculates the necessary checksums and builds a 
valid ECM calibration file that can be used to program an EPROM for the ECM. 
 

Calibration Tables 
The C.A.T.S. Tuner program uses three different formats of calibration tables to display the various 
ECM calibration values. 
 
Switch Type Calibration Table 
The switch type calibration table will contain all the calibration items that can only have tow values or 
states such as  on  or  off , or  Enabled  or  Disabled . This type of table will contain calibration items 
such as  V.A.T.S.  enabled/disabled.  
 

 
 
Each ECM calibration file will only have one Switch table that will contain all the appropriate 
calibration values.  
 
Note: Some ECM s do not have any switch type calibration values in which case the Switch Table will 
be empty. 
 
Constant Type Calibration Table 
The Constant Table is used to present calibration values that represent single values or calibration 
constants such as fuel cutoff RPM or injector flow rates. 
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Like the Switch table, each ECM calibration file will contain one Constants Table that will contain all 
the constants for that ECM. 
 
2D and 3D Calibration Tables 
The majority of the ECM Calibration Tables will be either 2D or 3D tables. These tables are used to 
display a series of values that depend on one (2D tables) or 2 other parameters (3D tables).  
 
An example of a 2D table might be the Target Idle RPM versus Coolant Temperature.  
 

 
 
A good example of a common 3D table would be the Main Spark Advance versus RPM versus Manifold 
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Pressure. 
  

 
 
 
 
Opening A Calibration Table 
Once an ECM Calibration File has been opened, you can view a calibration table by clicking on the  
Tables  menu and then selecting the desired table from the drop-down list.  
 
This list will contain all the tables available for the selected ECM Definition File. 
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To make the calibration tables easy to understand and more convenient to edit, the C.A.T.S. Tuner 
program displays all table values in correct engineering units rather than the binary values actually 
stored in the calibration file.  
 
You may view as many tables at once as you want. To view another table, simply select it from the 
drop-down list. To close a table, click on the window close box (X) in the upper right hand corner of the 
table.  
 
Note: You will NOT lose any changes that have been made to a table by closing it. 
 
The displayed table can be sized in height or width by clicking on an edge and dragging it to the desired 
size. Use the ‘Windows’ menu to arrange the tables you have open. 
  
 
 
 
Viewing Calibration Table Graphs 
In addition to viewing the 2D or 3D ECM tables in tabular form, each table can be displayed graphically 
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(This feature is not active for the Switches and Constants tables). Two-dimensional tables are graphed 
using two-dimensional graphs and three-dimensional tables use three-dimensional graphs. The graph can 
be viewed by itself or along with the table. 
 

To view a table graphically, open the desired table and click on the 'Graph Only'  button on the 
toolbar. Alternately you can select 'Full Graph' from the 'Options' menu.   
 

 
 
This will display the table as a graph as shown below. 
  

 
 
Note the data box in the lower right corner of the screen. This box shows the information about the data 
point at the cursor position on the graph and is updated continuously as you move the cursor over the 
graph. 
 
 

To view the graph and the table at the same time, click on the 'Graph and Table' button  or select 
'Table/Graph' from the 'Options' menu. 
 



Computer Automotive Tuning Systems 

Page 19 

This will display a graph of the table above the numerical table. The graph will be sized to fit into the 
current table window. To make the graph larger, increase the size of the table window. 
  

 
 
You can change a table value from the graph by clicking on the data point you want to change and 
dragging the point while holding down the left mouse button.  
 
You can change the view of the graph by rotating, moving, zooming or scaling the graph with the 
keyboard and you mouse. See the Changing 3D Graph Views and Changing 2D Graph Views sections 
for details. 
 

To return to the table only view, click the 'Table Only'  button or select 'Full Table' from the 
'Options' menu. 
  
 
 
 

Changing 2D Graph Views 

The view of the 2D graph can be changed to make it easier to view the table data points by using 
keyboard and mouse commands. The following commands are available for 2D graphs: 
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Zoom Graph Window To zoom in on a particular area of the graph, hold down the Control key and the 
left mouse button and drag the mouse over the area to zoom. Press the  R  to return to the original zoom 
level.  Move Graph To move the entire graph within the table window, hold down the  Shift  key and 
the right mouse button and drag the graph in the desired direction.  Scale Graph To scale the entire 
graph, hold down the  Alt  key and the left mouse button and drag the mouse up to make the graph 
bigger or down to make the graph smaller.  
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Changing 3D Graph Views 

The view of the 3D graph can be changed to make it easier to view the table data points by using 
keyboard and mouse commands. The following commands are available for 3D graphs: 
  

 
 
Rotate Graph To rotate a 3D graph, hold down the  Shift  key and the left mouse button and drag the 
mouse to rotate the graph. Moving the mouse up and down rotates the graph about the x axis; moving 
the mouse left and right rotates the graph about the z axis; and moving the mouse diagonally rotates the 
graph about the y axis. 
 
Rotating the graph will allow you to view and edit points that would otherwise not be visible. 
 
 Zoom Graph Window To zoom in on a particular area of the graph, hold down the Control key and the 
left mouse button and drag the mouse over the area to zoom. Press the  R  key to return to the original 
zoom level.  Move Graph To move the entire graph within the table window, hold down the  Shift  key 
and the right mouse button and drag the graph in the desired direction.  Scale Graph To scale the entire 
graph, hold down the  Alt  key and the left mouse button and drag the mouse to make the graph bigger 
or down to make the graph smaller.  
 

Editing Calibration Values 
The main function of the C.A.T.S. Tuner program is to allow you to easily edit the calibration values in 
an ECM calibration file. There are a variety of tools provided for editing depending on whether you're 
editing a Switch Table, a Constants Table or a 2D or 3D Table. To begin editing a table, select the 
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desired table from the 'Tables' menu. 
  

 
 
  
 
Editing Switch Type Calibration Table Values 
To edit Switch calibration values, open the Switches table.  
 

 
 
By definition, Switch values can be either  On  (enabled) or  Off  (disabled). To change the state of a 
Switch value, click on the box to the left of the switch label. 
  

 
 
If there is an  X  in this box, then the corresponding Switch is enabled. If the box is empty, then the 
Switch is disabled. 
 
Editing Constant Type Calibration Table Values 
After opening the Constants Table, there are three ways you can change the values of the Constants.  
 
To make small changes, you can click on the up/down arrows to the right of the Constant name. Each 
time you click the  up  arrow the Constant value will be incremented by one edit step. Clicking the  
down  arrow will decrement the value by one edit step. 
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To make larger changes, click on the slide control below the Constant name and drag the slide control 
up or down. The value will change as you drag the slide. Stop when you reach the desired value. 
  

 
 
You can also simply click on the value box and type in a new value. While you can type in any value, 
the program will convert the value you typed in to the nearest valid value for this constant.  
 
There are minimum and maximum allowable values for each Constant. When using the slide control or 
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the up/down arrows, the program will prevent you from exceeding these limits. If you type in a number 
less than the allowable minimum, you will receive the following error message: 
  

 
 
To use the minimum allowable value, click  OK . Click  Cancel  to return to the previous value. 
Similarly, if you type in a value greater than the allowable maximum, you will receive an error message 
that will ask you if you would like to use the maximum allowable value.  
 

Selecting 2D and 3D Table Cells 
To edit values in the tables, you must first select the cell or cells containing the values to be changed. To 
select a single table cell, simply click on the desired cell with the left mouse button.  
 
To select a range of cells, click on the first cell with the left mouse button and drag the mouse while 
holding down the left mouse button to highlight the desired range of cells. 
  

 
 
To select an entire column, click on the column heading with the left mouse button. The selected column 
will be highlighted.  
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To select an entire row, click on the row header. This will highlight the selected row. 
  

 
Editing 2D and 3D Table Values 
Once one or more table cells are selected, there are several ways to change the values in these cells. You 
can increment, decrement, add subtract, scale (multiply) or fill the selected cells.  
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If the table graph is displayed you can also drag the points on the graph to change the table values. 
  

 

All the edit functions are available by clicking on the 'Edit' menu or by right-clicking 
on the selected cells. 

Increment/Decrement 

You can increment or decrement the values in the selected selected cells by a predefined edit step size. 

In addition to selecting 'Increment' or 'Decrement' from the 'Edit' menu you can also click on the  , 

,  buttons on the toolbar or you can use the keyboard '+' and '-' keys. 

Add  

Selecting 'Add' from the 'Edit' menu displays the 'Add Value' screen which allows you to enter a value 
that will be added to the values in the selected cells.  
 
Click 'OK' to add the value or 'Cancel' to keep the original cell values.  

 
 
  

Subtract  

Selecting 'Subtract' from the 'Edit' menu displays the 'Subtract Value' screen which allows you to enter a 
value that will be added to the values in the selected cells.  
 
Click 'OK' to subtract the value or 'Cancel' to keep the original cell values.  
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Fill  

Selecting 'Fill' from the 'Edit' menu or clicking on the 'Fill button  on the toolbar displays the 'Fill 
With Value' screen which allows you to enter a value that will be used to fill all the selected cells.  
 
Click 'OK' to use the new values or 'Cancel' to keep the original cell values.  
 

 
 
To quickly enter a value into a single cell, double click on the cell. This will display the 'Fill With Value' 
screen. 

Scale 

Selecting 'Scale' from the 'Edit' menu or clicking on the 'Fill button  on the toolbar displays the 
'Scale Value' screen which allows you to enter a value by which all the  selected cells will be multiplied. 
 
Click 'OK' to multiply the values or 'Cancel' to keep the original cell values.  
 

 
 
  
 

Drag Graph Points  

If the table graph is being displayed, table values can be changed by clicking on a point on the graph and 
dragging the point up and down. The corresponding value in the table will change as you drag the point 
on the graph. 
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While you can type in, fill, add or subtract or multiply by any value, the program will convert the 
resulting value to the nearest valid value for this table. 
  
There are minimum and maximum allowable values for each table. When using the 
increment/decrement buttons or when dragging a point on the graph, the program will prevent you from 
exceeding these limits. By entering a value directly, or using the fill, add, subtract or scale functions, the 
resulting values may be outside the allowable range. If any of the resulting values are less than the 
allowable minimum, you will receive the following error message: 
  

To use the minimum allowable value, click  OK .  
 
Click  Cancel  to return to the previous value(s). 

 
Similarly, if any of the resulting values are greater than the allowable maximum, you will receive a 
similar error message that will ask you if you would like to use the maximum allowable value(s).  

Copy and Paste Table Values 

Using the copy and paste function you can copy table values from 2D and 3D tables and paste these 
values into another portion of the same table, into a different table or even into the table from another 
calibration file. You can also copy and paste tables values to and from other Windows programs that 
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support the standard Windows clipboard function such as Microsoft Excel and Word. 
 
To copy table values, select the values from the source table and then select 'Copy' from the 'Edit' menu 
or right click on the selected values and select 'Copy' from the popup menu. You can also use the Copy 

button  on the toolbar or you can use the standard 'cntl-c' Windows shortcut. 
  

 
 
To now paste these values into the another table, right click on the first cell of the paste area (cell in the 
new table that corresponds to the top, leftmost cell of the source selection) and select 'Paste' from the 
popup menu (or click on the target cell and select 'Paste' from from the 'Edit' menu. You can also click 

on the Paste button  on the toolbar or use the standard 'cntl-v' Windows shortcut. 

  
 
This will paste the values from the source table into the target table or target application.  
 
Note: If you highlight an area in the target table (not just the first cell), then you must highlight an area 
that is the same size and shape as the area selected from the source table. If the source and target areas 
do not match, you will receive the following error message: 
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Similarly, if you select a start cell in the target table that does not allow the same number of cells to the 
left of and down from the start cell (ie. target table not big enough), you will receive this same error 
message.  
 
Undo / Redo Functions 
Regardless of the type of table being editing, the Tuner program provides 'Undo' and 'Redo' functions. 
The 'Undo' function will reverse the changes made by the last edit. You can undo up to ten changes. If 
you undo a change and then decide you really wanted to use that change, you can use the 'Redo' function 
to re-apply the last change that was reversed using Undo. 
 

To undo the last change, click on the Undo button   or select 'Undo' from the 'Edit' menu. 
  

 
 
 

Similarly, to redo a change, click on the Redo button  or select 'Redo' from the 'Edit' menu. 
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Importing Table Values 
The import function allows you to import the table values from another calibration file of the same type. 
To import table values, select 'Import' from the 'Edit' menu. 
  

 
 
 
This will display a standard file open dialog box. Select the desired calibration file from the dialog box 
and click on the 'Open' button. 
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The table values will then be read from the selected calibration file and inserted into the active table. 
Only the active table is changed. No other tables, open or not are altered. 
  
You can not import values from a calibration file of a different type. If you open a different type 
calibration file by mistake, you will receive the following error message. 
  

 
 
Restore Table Values 
If you make several changes to table values and decide that you do not want to keep any of these 
changes, you can restore the table values to the last saved values using the Restore Table function. 
  
To restore the values in a table, select 'Restore Table' from the 'Edit' menu. 
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This will restore the tables values to the values that were in the table when you last saved the calibration 
file to disk. Only the active table is affected. 
 
Calibration Tools 
The 'Tools' menu provides several useful calibration utilities that are active when you are using the $EE 
ECM Definition File.  
 
The following utilities are accessed from this menu: 
  

Speedometer Calibration 
VIN Information 
Calibration Notes 
Read PCM 
Program PCM 

Note: The 'Tools' menu will be inactive when you are using any other ECM Definition File. 

Speed Calibration 

The Tuner program includes a speed calibration utility that can help you calculate the calibration 
parameters that determine the speed calibration. These calibration parameters need to be changed if you 
change the rear-end ratio or tire size. To access this utility, select 'Speed Calibration' from the 'Tools' 
menu. 
 

 
 
The Speedometer Calibration screen will then be displayed. 
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There are two ways to calculate the speed calibration parameters; by tire size or by the number of 
revolutions per mile of the tire. The most accurate way is to determine the actual revs per mile for your 
vehicle but you can enter the tire size and the program will calculate an approximate revs per mile. 
 
To use tire size, click on the 'Tire Size' option button and enter the tire size in the boxes provided. To use 
revolutions per mile, click on this option button and enter the appropriate revs per mile. 
 
To properly calculate the vehicle speed, the PCM also needs to know how many pulses per revolution of 
the driveshaft are generated by the speed sensor. If you are using the original transmission, click on the 
'Stock Speed Sensor' option button in the Speed Sensor Information Box' and then select the appropriate 
'Car Type' and 'Transmission Type'.  The Tuner program will then insert the correct value of pulses per 
revolution. 
  
If you are using a non-standard transmission, then you will have to enter in the correct number of pulses 
per driveshaft revolution for the speed sensor that is being used. To enter in this value directly click on 
the 'Pulses Per Driveshaft Rev.' option button. This  will disable the 'Stock Speed Sensor', 'Car Type' and 
'Transmission Type' option buttons and enable the 'Pulses Per Driveshaft Rev.' text box. Enter in the 
correct value of pulses per revolution for your speed sensor.  
 
Finally enter in your rear end ratio. 
 
To calculate the new speed calibration parameters, click on the 'Calculate' button. The 'New Calibration 
Values' box will now display the speed calibration parameters. The 'Current Calibration Values' box 
displays the current calibration parameters stored in the calibration file for comparison. 
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When you are satisfied with the new values, click on the 'Apply' or the 'OK' buttons to enter these new 
parameters into the calibration file (just as if you changed them from the Constants Table.) The 'Apply' 
button applies the changes but leaves the Speedometer Calibration screen open. Clicking on the 'OK' 
button also applies the changes but closes the Speedometer Calibration screen. 
 
Click on the 'Cancel' button to close the Speedometer Calibration screen without making any changes to 
the calibration file. 
 
If you use tire size, you should get close to the correct calibration values but you may have to make 
some corrections after testing. To then fine tune the speedometer calibration further, use revs per mile to 
make small adjustments. 

VIN Information 

Type $EE calibration files contain a copy of the VIN which can be read by the Tuner program. Select 
'Check VIN' from the 'Tools' menu to view the VIN from the calibration file.  
 

 
 
This will display the VIN information screen which shows the actual VIN number along with all the 
information that is contained within the VIN. 
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Note: The actual VIN is stored in EEPROM on the microprocessor and cannot be changed by editing the 
copy that appears in the calibration file from the FLASH memory.  

Calibration Notes 

If you are working with the $EE ECM Definition File, you can add calibration notes directly to the 
calibration file. These notes are stored in an area that is not used by the PCM and have no effect on the 
calibration. The notes field can contain up to 255 ASCII characters.  
 
To view, edit or add new calibration notes to your calibration file select 'Notes' from the 'Tools' menu. 
  

 
 
 
 
This will display the Notes screen. 
  

 
 
You can type into and edit directly in the Notes box. To completely erase the current notes, click on the 
'Clear' button. When you are finished editing the notes, click on the 'OK' button to save your changes or 
the 'Cancel' button to discard any changes you have made. 

Read PCM 

The 1994 – 95 LT1 PCM and the 1994 – 95 L32 and L82 V6 PCM do not use a removable EPROM to 
store the calibration information like the older GM ECM's. These PCM's use FLASH memory that must 
be read and reprogrammed using the car's ALDL connector.   
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Before proceeding be sure you have specified the correct Comm port that you will be using to 
communicate with the PCM. To set the correct Comm port, select 'Comm Port Setup' from the 'Options' 
menu. This will display the following screen:  
 

 
 
Select the Comm port you wish to use and click 'OK'. The program will save this selection so you don't 
have to set the Comm port again unless you want to change to a different port.  
 
To read the calibration currently stored in the PCM, select 'Read PCM' from the 'Tools' menu.  
 

 
 
This will display the read PCM start screen. 
  

 
 
Before proceeding, connect the RS-232 to ALDL converter interface cable to the Comm port on your 
PC. If your PC has more than one Comm port, make sure you connect the converter to the com port that 
you specified on the Comm Port Setup screen.   
 
Connect the other end of the converter to the ALDL diagnostics connector on the vehicle.  
 
Once the cable is connected, turn the ignition key on but DO NOT start the engine. After turning on the 
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ignition, wait about 10 to 15 seconds to clear the GM security delay before proceeding with 
programming.  
 
Now click on 'OK' to begin the PCM read process. If all the connections have been properly made, the 
program will begin communicating with the PCM, sending the necessary instructions to start the 
memory read process.   
 
The following status window will be displayed during the read process: 
 

 
 
The progress meter shows the progress on the reading of the PCM as it proceeds and the Status window 
describes what part of the process in currently underway. Depending on the PC you are using, the 
programming will usually take about five minutes. If the process does not complete correctly for some 
reason, an error message will be displayed in the Status window. See Appendix B for a description of 
the possible error messages.  
 
If the read process gets interrupted before completion, you may have to reset the PCM before it will 
function correctly. Refer to Appendix A – Recovering and Resetting the PCM for details.  
 
When the FLASH read process is complete, the message shown below will be displayed: 
  

 
 
Click 'OK' to complete the PCM read and close the Read Complete message box. 
 
The calibration from your PCM will now be loaded into the Tuner program and you can now view and 
edit the calibration parameters as needed. 
 
NOTE: Its a good idea to save a copy of the original stock calibration to your hard disk before making 
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any changes. This way, you'll have a baseline to return to if necessary. For details see the section on 
Saving A Calibration File.   
 

Program PCM 

The 1994 – 95 LT1 PCM and the 1994 – 95 L32 and L82 V6 PCM do not use a removable EPROM to 
store the calibration information like the older GM ECM's. These PCMs use FLASH memory that must 
be read and reprogrammed using the car's ALDL connector.   
 

WARNING  
 

If the programming process does not complete successfully it is possible to damage the 
PCM. Under no circumstances should you interrupt the programming process once it is 

started. 
 
The following are recommendations for the successful programming of your PCM:  

 Before programming the PCM, make sure you can successfully read the PCM. This is a very 
similar process and if that is successful, then the programming should also work fine. YOU CAN 
NOT DAMAGE YOUR PCM BY READING IT.  

 Make sure the car battery is in good condition and fully charged. DO NOT try to program the 
PCM with a battery charger connected to the car battery. The correct range of the battery voltage 
for PCM programming is relatively narrow.  

 If you're using a laptop, make sure the laptop battery is fully charged.  
 Make sure you have good connections between the PC, ALDL connector and the interface cable 

and that they are not likely to be unintentionally disconnected during the programming process.  
 Disable all power management functions on your PC.  
 Disable all screen savers on the PC.  
 Make sure there are no other applications (programs) running on your PC, including virus 

checkers.  
 
Before proceeding be sure you have specified the correct Comm port that you will be using to 
communicate with the PCM. To set the correct Comm port, select 'Comm Port Setup' from the 'Options' 
menu. This will display the following screen:  
 

 
 
Select the Comm port you wish to use and click 'OK'. The program will save this selection so you don't 
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have to set the Comm port again unless you want to change to a different port.  
 
The PCM will be programmed with the calibration that is currently loaded into the Tuner program. See 
the Opening A Calibration File section for details. Note: Any changes made since opening the 
calibration file will be included in the calibration when the PCM is programmed.    
 
To program a new calibration into the PCM, select 'Program PCM' from the 'Tools' menu.  
 

 
 
This will display the Program PCM start screen. 
  

 
 
Before proceeding, connect the RS-232 to ALDL converter interface cable to the Comm port on your 
PC. If your PC has more than one Comm port, make sure you connect the converter to the Comm port 
that you specified on the Comm Port Setup screen.   
 
Connect the other end of the converter to the ALDL diagnostics connector on the vehicle.  
 
Once the cable is connected, turn the ignition key on but DO NOT start the engine. After turning on the 
ignition, wait about 10 to 15 seconds to clear the GM security delay before proceeding with 
programming.  
Now click on 'OK' to begin the PCM programming process. If all the connections have been properly 
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made, the program will begin communicating with the PCM, sending the necessary instructions to start 
the memory programming process.  The following status window will be displayed during the read 
process: 
  

 
 
The progress meter shows the progress on the programming as it proceeds and the Status window 
describes what part of the process in currently underway. Depending on the PC you are using, the 
programming will usually take about five minutes. If the process does not complete correctly for some 
reason, an error message will be displayed in the Status window. See Appendix B for a description of 
the possible error messages. 
 
If the programming process gets interrupted before completion, you may be able to recover the PCM. 
Refer to Appendix A – Recovering and Resetting the PCM for details.  
 
When the FLASH programming process is complete, the message shown below will be displayed: 
  

 
 
Click 'OK' to complete the PCM programming and close the Programming Complete message box. 
 
The calibration that was loaded into the Tuner program has now been transferred to the PCM and is 
ready for testing. 
 
 

Comparing ECM Calibration Files 
 A unique and useful feature of the C.A.T.S. Tuner program is the ability to compare two ECM 
calibration files. When the Compare function is enabled, the values in all tables will represent the 
difference between the primary ECM Calibration file and the Compare ECM Calibration File (primary 
file value   compare file value). 
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Opening A Compare ECM Calibration File 
To use the Compare function, you must open a Compare ECM Calibration file after opening your 
primary (the calibration file you are going to edit) ECM Calibration File.  
 

  
 
To open the compare file, select 'Compare File' from the 'Files' menu.  

 
This will display the 'Open File' dialog box. Select the desired compare file and click the 'Open' button. 
  

 
 
If you are using the $EE ECM Definition File, the Tuner program will accept .lt1 format files as well as 
standard binary format files as compare files. You can even compare an .lt1 file to a binary file.   
 
To open an .lt1 format file as the compare file, click on the drop-down arrow to the right of the 'Files of 
type' box and select lt1 Files (*.lt1) from the drop-down list. 
  
The file box will then show all the available .lt1 files in the current subdirectory.   
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Viewing A Calibration Table in Compare Mode 
After opening an ECM Calibration compare file, you can view any table in the compare mode by 

opening the desired table and then clicking on the Compare  button on the toolbar or selecting 
'Compare' from the 'Options' menu. 
  

 
 
The values displayed in the table will now be the difference between the values from the two calibration 
files. In the case of the Switch Table, if a Switch is not set the same in both calibration files, the Switch 
name will be displayed in Italics to designate that the two files are different. 
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If the table graph is displayed, the graph will show the differences as well. 
 

To switch back to normal view mode, click the Compare  button again. 
 
You can also edit the table values when in the compare mode allowing you to see you changes relative 
to the Compare file. 
 
Note: When a table value is edited in the Compare mode, only the primary calibration value is being 
changed. No changes are made to the Compare Calibration file.  

 
Generating Reports 
 
Printing An ECM Calibration Table 

To print a calibration table, first open the table then either click on the Print  button on the toolbar or 
select 'Print Table' from the 'Files' menu. The selected table will be scaled to fit the page and printed as 
it appears on the screen. 
  

 
 
 
Printing An ECM Calibration Table Graph 
To print a 2D or 3D calibration table graph, display the graph and then select 'Print Graph' from the 
'Files' menu. The selected table graph will be scaled to fit the page and printed as it appears on the 
display.   
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Print All ECM Calibration Tables 
This function allows you to print all the calibration tables at once in text format and quickly creates a 
compact hardcopy of your calibration.  
 
To print all the calibration tables in the open calibration file select 'Print All' from the 'Files' menu. 
  

 
 
The following message will then be displayed giving you the option to continue or to cancel the 
printing: 
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To continue with the printing click 'OK'. To cancel the print click on the 'Cancel' button. 
 
All the calibration tables (including the Switch Table and the Constants Table) will be printed (as many 
tables per page as will fit) in text format similar to that shown below. 
  
 
  

 
 

Printer Setup 
To change the printer properties such as the selected printer, paper size and orientation, select 'Print 
Setup' from the 'Files' menu. 
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This will display the standard Windows printer setup screen. 
  

 
 
Make the desired changes and click on the 'OK' button to apply the changes or click on 'Cancel' maintain 
the current settings. 
 
Print All ECM Calibration Tables To A File 
This function allows you to print all the calibration tables at once in text format to a text file rather than 
creating a hardcopy on your printer. The resulting text file is a convenient way to document you 
calibrations and can be easily edited to add comments or can be embedded into other documents.     
 
To print all the calibration tables in the open calibration file to a text file, select 'Print All' from the 
'Files' menu. 
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A standard file save dialog box will be displayed to allow you to enter a file name to be used to save the 
file. 
 

 
 
Enter the desired file name and click on the 'Save' button to complete the print all to file function. 
 
  

Default Path 
If you wish you may setup the program to go to a default directory for any file operation. 
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To specify a default path for the program, select 'Default Path' 
from the 'Files' menu. 

 
  

 

  
 
The default path window will be displayed. Select the desired 
default path and click on the 'OK' button. 

 
This default path will be saved and will be active until another default path is selected. 
 
Program Options 
The 'Options' menu provides some choices on how the Tuner program operates. The first four entries in 
the 'Options' menu allow you to toggle four program functions on and off; Toolbar display, Calibration 
Table Compare, Calibration Table Graph display, and Full Preview. The 'Preferences' selection from the 
menu allows you to set the number of files listed in the history file list in the 'Files' menu and to control 
the number or items listed in each column of the program drop-down menus. 
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If the 'Toolbar' option is unchecked, the toolbar is removed from the top of the screen giving you a 
larger view window for the calibration tables. 
  
Checking the 'Compare' selection activates the compare display mode and has the same function as the 

'Compare'  button on the toolbar. The option is only active if a Compare File is open.  
 
Checking the 'Full Graph' selection displays a graph of the calibration table currently being viewed. 

This has the same function as the Graph Only  button on the toolbars. The option is only active if 
you are viewing a 2D or 3D Calibration Table. 
  
Checking the 'Table/Graph' selection displays a graph along with the tabular view of the calibration 

table currently being viewed. This has the same function as the Graph and Table  button on the 
toolbars. The option is only active if you are viewing a 2D or 3D Calibration Table. 
  
Checking the 'Full Table' selection displays the table currently being viewed in tabular form only. This 

has the same function as the Table Only  button on the toolbars. The option is only active if you are 
viewing a 2D or 3D Calibration Table. 
  
The next selection in the 'Options' menu is 'Full Preview'. If this selection is checked, a 3D Calibration 
Table graph will be fully displayed while you are changing the orientation of the graph. When this 
selection is unchecked, a wire frame representation of the graph axes is displayed when changing the 
orientation of the graph.  
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This function is useful on slower computers where changing the graph orientation may be unacceptably 
slow with 'Full Preview' selected. 
  
The currently selected table can be printed in either test form or in graphic form. If the 'Graphic Table 
Print' option is selected, then the table will be printed as it appears on the screen. 
  
Normally whenever you make a change to a value in a table, the value will be displayed in red to 
indicate the value has been edited. Unchecking the 'Change Indicators' option turns off this function. 
  
When change indicators are enabled, the edited values will remain red until the file is closed and re-
opened. Just saving the file while editing does not clear the change indicators. If you wish to clear the 
change indicators during an editing session, click on the 'Clear Change Indicators' selection in the 
menu. See the Editing Calibration Values section for more details. 
 
  
 
Selecting 'Preferences' from the 'Options' menu will display the Program Preferences screen. 
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From this screen you can change to number of files that are listed in the file history list in the 'Files' 
menu. You can set this number at any value from 1 to 15.  The default value is five and as shown in the 
example below, this will display the five most recently opened calibration files at the bottom of the 
'Files' menu. 
  

 
 
The Program Preferences screen also allows you to set the number of items that will be displayed in 
each column of a drop-down menu. Depending on your computer monitors size and resolution, the 
longer drop-down menus may run off the bottom of the screen. This function allows you to set the 
maximum number of items in a drop-down menu column. If there are more items in a drop down menu, 
then a second column is displayed as shown below: 
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This value can be set from 10 to 99 items column. The default is 33. 
  
If you are using the $EE or V6 ECM Definition Files, then the 'Comm Port Setup' selection will be 
visible in the 'Options' menu. Clicking on this item will display the Comm Port Setup Screen: 
  

 
 
This screen allows you to select which comm port on your PC will be used when communicating with 
the PCM for reading and programming the PCMs FLASH memory. To select the desired comm port, 
click on that port and then click 'OK'. 
  

Window Arrangement 
The 'Window' menu gives you several options for arranging multiple calibration tables that you have 
open. 
  

 
 
The 'Cascade' selection, overlays all the open tables on top of each other so that the title bars of each 
table are visible. 
The 'Tile Vertically' selection displays each open table side by side on the screen. 
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The 'Tile Horizontally' selection will display each open table the full width of the main window and 
divide the window vertically evenly for each open table. 
  

Comments and Problem Reports 
We at C.A.T.S. are continually trying to improve our products and to do so we rely heavily on inputs 
from users and we welcome all comments and suggestions. Please e-mail us at tc@.tunercat.com with 
any comments or suggestions and to report any operational problems. 
 

Software License, Copyright And Warranty 
 COPYRIGHT The C.A.T.S. Tuner software is copyright 2002 with all rights reserved. The distribution 
and sale of this software are for the exclusive use of the original purchaser for use exclusively on 
computers privately owned by that purchaser. Unauthorized copying, duplicating, selling, or otherwise 
distributing the software is in violation of the Federal Copyright Law.  LICENSE AGREEMENT Use 
of this product constitutes acceptance of these terms and conditions and an agreement to abide by them. 
This is a license agreement and not an agreement for sale. Computer Automotive Tuning Systems owns, 
or has licensed from the owner, copyrights in this software. The original purchaser is granted a personal, 
nonexclusive, non-transferable license to use this software under the terms stated in this agreement. You 
may not assign or transfer the software or this license without the express written consent of Computer 
Automotive Tuning Systems. Any attempt to sublicense, assign, or transfer any of the rights, duties, or 
obligations there under is void. You may not copy (except for backup purposes), modify, alter, 
electronically transfer, lease or rent the software. This license is in effect until terminated. You may 
terminate it at any time by destroying the software. It will also terminate if you fail to comply with any 
of the terms and conditions of this agreement. If the license terms are not acceptable, remove the 
software from your computer.  LIMITED WARRANTY AND DISCLAIMER Computer Automotive 
Tuning Systems warrants for a period of ninety (90) days from the date of delivery that the software, 
under normal use, will substantially perform as described in the documentation when used on the 
supported hardware and system software. 
 
Computer Automotive Tuning Systems  entire liability and your exclusive remedy under this warranty 
will be at Computer Automotive Tuning Systems  option, to attempt to correct or help you work around 
errors, replace the software with functionally equivalent software, or to refund the purchase price and 
terminate this Agreement. 
 
EXCEPT FOR PRIOR EXPRESS LIMITED WARRANTIES, COMPUTER AUTOMOTIVE 
TUNING SYSTEMS MAKES, AND YOU RECEIVE, NO WARRANTIES, EXPRESS, IMPLIED 
STATUTORY OR IN ANY COMMUNICATION WITH YOU, AND COMPUTER 
AUTOMOTIVE TUNING SYSTEMS SPECIFICALLY DISCLAIMS ANY IMPLIED 
WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
COMPUTER AUTOMOTIVE TUNING SYSTEMS DOES NOT WARRANT THAT THE 
OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE. 
 LIMITATION OF LIABILITY IN NO EVENT WILL COMPUTER AUTOMOTIVE TUNING 
SYSTEMS BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING LOST PROFITS, LOST 
SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING FROM 
THE USE OF THE SOFTWARE, EVEN IF COMPUTER AUTOMOTIVE TUNING SYSTEMS 
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  
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Software Registration 
When you purchase the Tuner program you will receive your program registration information. To 
register your copy of this software start the program and select 'Register' from the 'Help' menu. 
  

 
 
  
When the registration form appears, enter your Customer ID and Serial Number into the appropriate 
boxes. Note that the Customer ID is case sensitive and should be entered exactly as received. Enter your 
Serial Number carefully. Also note that all letters in the Serial Number are all upper case. 
 

 
 
Note: If your evaluation period has expired, the registration form will be displayed automatically when 
you run the program. 
  

Program Updates 
As a registered user, you are entitled to free updates to the Tuner program and any ECM Definition Files 
you have purchased.  
 
Check the ‘Version Information’ page on our web site (www.tunercat.com) to see a list of the current 
versions of the Tuner program and all the ECM Definition Files. 
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You can download the latest version of the Tuner program from the ‘Donwloads’ page on our web site 
(www.tunercat.com). If you install the latest version of the Tuner program into the same folder as you 
current version, you won’t need to re-enter you registration information or move you ECM Definition 
Files. 
 
To obtain the latest version of an ECM Definition File, just send us an e-mail at tc@tunercat.com and 
request the ECM Definition File updates you need. We will then e-mail the latest version of the ECM 
Definition File to you. 
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Appendix A – Recovering and Reseting the PCM 
If the PCM read process is interrupted before completion at certain times during the process, the PCM 
may no longer communicate and thus will not function correctly. To recover from this, you'll need to 
completely reset the PCM. 

To reset the PCM, you must remove all power from the PCM for about 10 to 15 minutes. To do this you 
can either disconnect the main battery cable from the battery or you can disconnect the four connectors 
going to the PCM. This should reset the PCM and it should function normally afterward. 

If the PCM programming process is interrupted before completion, you may still be able to recover 
depending on at what stage the interruption occurred. If the programming process does get interrupted 
for some reason, FIRST just retry the programming process BEFORE turning off the ignition. If that 
doesn’t work try resetting the PCM as described above. Sometimes, this will recover the PCM and it 
will work properly or at least work enough to program it again. 

If after trying the reset, the PCM will still not communicate, then it has most likely been damaged and 
will have to be repaired or replaced. You can use your damaged PCM as a core and get a replacement 
from the dealer or you can have the PCM repaired. C.A.T.S. offers a repair service for these PCM's.  
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Appendix B - PCM Read/Program Communications Errors 
The following is a list of the possible error messages that may occur when you are reading or 
programming your PCM.  

NO MESSAGE SENT - CABLE FAILURE – Your will receive this error message whenever your PC is 
unable to communicate with the RS-232 to ALDL Signal Converter. This can be the result of not having 
the converter connected to the PC, having it connected to the wrong Comm port or a hardware failure in 
the converter.  

INVALID COM PORT SELECTED – This error message will be displayed if you select a Comm port 
that does not exist on your PC.  

NO RESPONSE FROM PCM – If the program receives no communications from the PCM, the message 
will result. This is generally caused by not having the RS-232 to ALDL Signal Converter connected to 
the diagnostic connector or not having the ignition on.  

ENGINE IS RUNNING – You will receive this error message if you attempt to read or program the 
PCM when the engine is running.  

BATTERY VOLTAGE OUT OF RANGE – Before programming your PCM, the program checks the 
battery voltage. If the battery voltage is out of the acceptable range (too low or too high), this error 
message will be displayed.  

SECURITY VIOLATION – If you receive this error message, you didn't wait long enough after turning 
on the ignition to try to read or program the PCM. Part of GM's security system is a delay after power-
up during which you can not access the PCM. Turn off the ignition key and wait for about 30 seconds to 
reset security violation status flags. Before attempting to program the PCM again, turn on the ignition 
and wait about 15 seconds before proceeding with the programming of the PCM.  

INCORRECT MESSAGE SENT – This error message indicates that the message that was actually sent 
to the PCM is not the message the program is trying to send. This indicates that there is a problem with 
the RS-232 to ALDL Signal Converter or the connection to the PC or there is some local source of 
electrical noise interfering with the communications.  

TOO MANY WAIT MESSAGES – This error message will be displayed if the program was unable to 
erase the PCM’s FLASH memory. This is most likely caused by a problem in the PCM.  

PROCESSOR RESET ERROR – This message indicates that the program was unable to reset the PCM 
after reading or programming memory. If you receive this message remove power from the PCM to 
reset the PCM before using it. This can be bone by either disconnecting the connectors from the PCM or 
disconnecting one of the battery terminals.  

PCM HARDWARE FAILURE – This message occurs if the PCM sends a hardware error message. This 
indicates an internal problem in the PCM.  

PCM MEMORY PROGRAMMING ERROR – This error message indicates that the program was 
unable to program the PCM correctly.  

A CHECKSUM ERROR HAS OCCURRED – This error message is displayed if the program receives a 
message from the PCM that has an incorrect checksum  
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INCORRECT RESPONSE FROM PCM – This error occurs if the program receives an unexpected or 
unknown message from the PCM indicating that the PCM may not be compatible with this program.  

INVALID RESPONSE FROM PCM – If the program receives a message from the PCM that is not of 
the correct message format, this error message will be displayed. This may be caused by hardware 
problems with the PCM or the RS-232 to ALDL Signal Converter or the interconnections. This message 
may also occur if the PCM is not compatible with this program.  

FLASH MEMORY CHECKSUM ERROR – After programming the PCM memory, the programming 
utility requests a checksum from the PCM and compares it to the checksum that was calculated during 
the programming process. These values should agree. If these values do not agree, then this message is 
displayed and indicates that the FLASH memory may not have been programmed correctly.  

 



Computer Automotive Tuning Systems 

Page 61 

Appendix C – Supported ECMs And PCMs 
This table lists the ECM Definition Files and the ECMs and PCMs that each Definition File supports. 
 

   Chevy and GMC Trucks:  
PROGRAM 

ID BYTE ECM P/N PLATFORM 

$27 1227137 86 Astro/Safari Van, LB4, 4.3L 

$76 1228934 85 - 93 C/K, Commercial Truck (HD), LB4 4.3L Manual 

$42 1227747 87 - 91 C/K Truck, Van, 4.3L, 5.7L & 7.4L 

$4F 1228747 87 - 92 C/K Truck, Van,  5.7L & 7.4L (HD) 

$4E 1228062 89 - 90 4.3L LB4, 2.8L LL2 S-10   

$A0 16144288 91 -  92 4.3L S-10 & C/K Truck 

$58  1227749 91 - 93 Syclone & Typhoon 

$85 16147060 or 
16127470 91 - 93 C/K Truck, Van,  5.7L & 7.4L (HD) 

$53 1227165   89 S10 Truck, 2.5L, LN8  

$94 1227165 or 
16156647 91 - 93 S10 Truck, 2.5L, L38 

$D3 16128420 92 - 93 C/K Diesel Truck L65, Auto Trans, TCM  

$D5 16156647 92 S10 Truck, Astrovan 4.3L L35 CPI 

$99 16146299 92 C/K Truck, Van, 4.3L, 5.7L & 7.4L 

$9A 
16156480, 

16196396 or 
16171199 

93 - 95 C/K Truck, Van, 5.0L & 5.7L,    Manual Trans.  

$E6 16168625 93 C/K Truck, Van, 4.3L, 5.0L & 5.7L 

$0D 16196395 or  
16197427 94 - 95 C/K Truck, Van, 4.3L, 5.7L & 7.4L 

$0DA 16196395 or  
16197427 94 - 95 Truck, Van, 4.3L L35 CPI  

$0E 16196395 or 
16197427 94 C/K Truck, Van,  5.7L & 7.4L (HD) 

 $31 16197427 or 
16156930  95 C/K Truck, Van,  5.7L & 7.4L (HD) 

$8C  16245358 95 C/K Truck, Van,  4.3L 

$8CA  16245358 95 Truck, Van,  4.3L L35 CPI 

 
 
 
 

    Chevy Cars: 



Computer Automotive Tuning Systems 

Page 62 

PROGRAM 
ID BYTE ECM P/N PLATFORM 

$1F 1226870 85 Y CAR 5.7L TPI (L98) 
85 F CAR 5.0L TPI (LB9) 

 $32 1227165 86 Y & F CAR 5.0L / 5.7L TPI 

$32B 1227165 87 - 88 Y & F CAR 5.0L / 5.7L TPI 

$3A 1227302  86 - 89 F CAR LB6/LB8 V6  

$41 1227746  87 Caprice/Monte Carlo 4.3L LB4  

$4D 1228063  88 F CAR 5.0L LO3 TBI  

$61 1228746 89 - 92 F & B Cars, LO3 & LO5 Eng. 

$6E 1227165 89 Y & F CAR 5.0L & 5.7L 

$88 1227730 90 - 92  F CAR LH0 V6 

$8D 1227727 or  
1227730 

90 - 91  Y CAR 5.7L TPI 
90 - 92  F CAR 5.0L & 5.7L TPI 

$8E 1228331 90 Corvette ZR1 (LT5) 

$AF 1228331 91 Corvette ZR1 (LT5) 

$62 16136965  91- 93 Caprice, LB4, L03 & L05 Eng.   

$D0 16163860 or 
16163993 92 Corvette ZR1 (LT5) 

$DA2 16159278 92 - 93 Y  CAR 5.7L, LT1 

$DA3 16159278 93 F CAR 5.7L, LT1 

$F0 16163993 or 
16196394 93 - 95 Corvette ZR1 (LT5) 

$EE ** 16181333 or 
16188051 

94 - 95 Y, F & B CAR, Cadillac 5.7L, LT1 (FLASH) (incl. 
'Rev B') 

 
** Note: The Rev B type $EE calibration was used in some early 1994 LT1s and requires the use of a separate 
ECM Definition File, the $EEB ECM Definition File.  
 
 

   Buick/Pontiac Cars:  
PROGRAM 

ID BYTE ECM P/N PLATFORM 

 $1D 1226459 84 - 85 LM9 3.8L V6 Turbo Buick/Pontiac 

$24A 1226869  85 Pontiac Fiero 2.8L V6  

$24 1227170  86 - 88 Pontiac Fiero 2.8L V6  

 $T31 1227148 86 - 87 Turbo Buick 

$48 1227748 
 87 - 88 Pontiac Fiero 2.5L 4 Cyl. LR8   
 87 - 90 Celebrity, 6000, Cutlass, Ciera, Century 2.5L 4 Cyl. 
LR8  
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$58A 1227749  87 - 90 Sunbird, Grand Am, 2.0L, LT3 
 Turbo   

$5B1 1228253  88 Buick / Pontiac LN3, 3800, V6  

$5B2 1228253  89 - 91 Buick / Pontiac LN3, 3800, V6  

$5B3 16141470  91 Buick / Pontiac L27, 3800, V6  

$5B4  16141470 92 - 93 Buick / Pontiac L67, 3800, Supercharged  

$5B5  16132792 or 
16141470 90 - 92 Pontiac W-Body L27, 3800, V6   

$5B   16183247 or 
16197428 94 - 95 Buick / Pontiac L67, 3800, Supercharged  

$6D 1227730  87 - 89 Buick / Pontiac LB6, 2.8L, V6  
 89 - 90 Buick / Pontiac LH0, 3.1L, V6 

$8F 1227727  89 - 90 Buick / Pontiac LG5 3.1L V6 MFI Turbo  

$A1 1227730  91 - 93 J, L, W Cars LH0 3.1L V6  

$DF 16149396  91 - 94 Buick / Pontiac LQ1 3.4L V6 
 93 - 94 Buick / Pontiac LH0 3.1L V6 

 
 

   Australian Holden:  
PROGRAM 

ID BYTE ECM P/N PLATFORM 

$5D 1227808 88 Australian Holden 

 
 

   Edelbrock Pro-Flow Systems:  
PROGRAM 

ID BYTE ECM P/N PLATFORM 

3500 Edelbrock Edelbrock Pro-Flow Systems 
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Appendix D – LT5 ECM Definition Files 
The Tuner program uses the calibration program ID to identify the calibration. Generally GM used the 
program ID to uniquely identify a calibration template and all calibrations with the same Program ID 
always had the calibration parameters were the same and located at the same place so the same ECM 
Definition could be used. 
 
Unfortunately, they did not follow this convention with the LT5 calibrations. There were two slightly 
different versions of each of the four program ID’s. Each version had some of the calibration parameters 
in different locations so two different versions of each ECM Definition File, a ‘standard’ version and an 
‘A’ version. 
 
The correct ECM Definition file that should be used depends on the particular calibration you are 
working with. The following table should be used to determine which version of the ECM Definition 
File should be used. To determine which version should be used determine the broadcast code of the 
calibration you are working with. The broadcast code is a four letter code that GM uses to uniquely 
identify each calibration. The broadcast code is usually printed on the ECM label and on the small silver 
label on top of the EPROM itself. Look up the broadcast code in the BC column of the table and find the 
corresponding ECM Definition File in the TDF column. 
 

MY ECM PN BC TDF Scan ID Chip PN Rel Date Disp Eng RPO 
90 1228331 ANHX 8E 5111 16129717 05/23/89 5.70 LT5 
90 1228331 AUAH 8E 8441 16148554 09/27/89 5.70 LT5 
90 1228331 AYBK 8EA 3921 16163905 11/03/93 5.70 LT5 
                  

91 1228331 ARZR AF 8371 16148990 03/19/90 5.70 LT5 
91 1228331 AXFK AF 291 16160276 09/11/90 5.70 LT5 
91 1228331 BFXB AFA 3431 16193416 11/10/93 5.70 LT5 
                  

92 16163993 AYWT D0 8001 16168043 06/14/91 5.70 LT5 
92 16163993 AZZC D0 2611 16172698 11/26/91 5.70 LT5 
92 16163993 BATL D0 5921 16175910 12/10/91 5.70 LT5 
92 16163860 BPPA D0A 9991 16219916 03/13/95 5.70 LT5 
                  

93 16163993 BAZJ F0 7401 16177557 05/21/92 5.70 LT5 
93 16163993 BFDM F0A 641 16190633 11/09/92 5.70 LT5 
93 16196394 BKKR F0 1461 16201452 11/12/93 5.70 LT5 
93 16196394 BMCB F0 9011 16209008 07/05/94 5.70 LT5 
                  

94 16163993 BFDM F0A 641 16190633 11/09/92 5.70 LT5 
94 16196394 BKKR F0 1461 16201452 11/12/93 5.70 LT5 
94 16196394 BMCB F0 9011 16209008 07/05/94 5.70 LT5 
                  

95 16163993 BFDM F0A 641 16190633 11/09/92 5.70 LT5 
95 16196394 BKKR F0 1461 16201452 11/12/93 5.70 LT5 

95 16196394 BMCB F0 9011 16209008 07/05/94 5.70 LT5 
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Appendix E - RT Tuner Instruction Addendum 
 
Introduction 
The C.A.T.S. RT Tuner was developed to allow ‘real-time’ ECM tuning when connected to the 
Transtronics (https://secure.transtronics.com) Romulator EPROM emulator or the Moates.net 
(www.moates.net) Ostrich or AutoProm emulators. With the emulator replacing the ECM’s original 
EPROM, you can make calibration changes while the engine is running and the changes will take affect 
immediately. 
 
Note: For the RT Tuner program to be compatible, you must have firmware version 1.09 or later 
in your Romulator. If you have any earlier version, please contact Transtroics for information on 
updating your Romulator.  
 
The RT Tuner program functions exactly the same as our standard Tuner program, except that whenever 
you make a calibration change the RT Tuner program sends the change (or changes) to the emulator. 
 
Note: The Romulator I only supports EPROM’s up to 256K in size. If you select an ECM Definition 
File for a calibration that uses a larger EPROM, such as the $0D ECM Definition File, the program will 
immediately disconnect from the Romulator and revert to normal ‘off-line’ (non-real-time) operation 
and function just like the standard Tuner program.  The Romulator II supports EPROM’s up to 512K in 
size. The Romulator also does not support the FLASH based PCM’s supported by the $EE ECM 
Definition File. 
 
When you run the RT Tuner for the first time, you will notice a new ‘Tools’ menu, some additional 
items in the ‘Options’ menu, a few new buttons in the toolbar and a new status bar at the bottom of the 
main screen. 
 
Background Calibration Updates 
The operation of the RT Tuner in real-time mode uses the emulator’s background update capability 
which allows the emulator’s memory to be updated in the background so that the update can be done 
while the ECM is running normally. Other than the calibration value change itself, the update is 
completely transparent to the ECM since the update to the emulator memory is done when the ECM is 
not accessing the emulator memory. 
 
Warning: Some functions can not be performed in background mode, specifically connecting to the 
emulator, reading the emulator and programming the emulator. As a result these functions should ONLY 
be performed with the engine stopped and the ignition turned off. Otherwise, the ECM will set error 
codes and damage to you engine could result.  
 
Quick Start  
The first time you use the emulator with you ECM, you have to make a few minor modifications to you 
ECM to allow you to be able to connect the Romulator to the ECM. 
 

1. Remove the ECM from the vehicle. 
2. Remove the access cover over the calibration chip or MEMCAL. 
3. If your ECM is an older ECM with a calibration chip in a plastic PROM carrier: 

A. Remove the PROM carrier and calibration chip. 
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B. Remove the circuit board from the metal housing 
C. Carefully unsolder and remove the special socket that the PROM carrier plugs into and 

replace it with a standard IC socket. Using a standard IC socket has the added benefit that 
you will no longer need the plastic PROM carrier (these part are obsolete and very difficult 
to find) so now you can just plug in a standard EPROM. Note: Make a note of pin 1 of 
the EPROM before removing the original socket to make sure you install the new 
socket correctly. 

D. Carefully remove the original EPROM from the PROM carrier and read it with your 
EPROM programmer. Save this file from the EPROM programmer software to your PC’s 
hard drive in binary format. This is the stock calibration file that you will use as your 
baseline calibration to which you’ll make the desired calibration modifications. 

E. Reinstall the circuit board into the metal housing. 
4. If your ECM is a newer ECM with a MEMCAL: 

A. Remove the MEMCAL from the ECM 
B. Carefully unsnap the cover from the MEMCAL (its usually blue or brown). 
C. Carefully unsolder the EPROM that’s now accessible from the MEMCAL. Note: Make a 

note of the orientation of the EPROM before removing it. 
D. Solder a standard IC socket in place of the original EPROM noting the correct orientation. 
E. Reinstall the MEMCAL in the ECM. 
F. Read the EPROM that you removed with your EPROM programmer. Save this file from 

the EPROM programmer software to your PC’s hard drive in binary format. This is the 
stock calibration file that you will use as your baseline calibration to which you’ll make the 
desired calibration modifications. 

 
You’ve now completed the necessary modifications to your ECM which you only need to do once. 
You’re now ready to connect the Romulator to your ECM. Note: Make sure the vehicles ignition is 
OFF during these next steps. 

1. Plug the emulator connector into the socket that you’ve just installed in your ECM noting the 
proper orientation (pin 1 if the connector is at the end with the red stripe on the emulator cable). 

2. Reconnect the ECM to the vehicle. 
3. Connect the serial cable to the emulator and to an available serial port on your PC.  
4. Run the RT Tuner program and wait for the program to connect  to the emulator. 
5. Load the calibration file that you created by reading the original EPROM from the ECM above 

into the RT Tuner program by selecting ‘Open’ from the ‘Files’ menu (or clicking on the Open 

File button  on the toolbar. Select the calibration file that you created and click on ‘Open’. 
6. Now program this calibration into the emulator. To program the emulator, you can either select 

‘Program Emulator’ from the ‘Tools’ menu or you can click on the Program Emulator button 

  in the main toolbar. 
You’re now ready to start real-time tuning. Start the engine and start tuning. Any calibration changes 
you make from the RT Tuner program will be sent immediately to the emulator so you can see the effect 
of your changes in real time. 
 
Program Startup 
When you start the RT Tuner program, the program will automatically attempt to connect to the 
emulator by searching all available serial ports. The first time you run the RT Tuner program, this may 
take a little while. 
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Once the program finds the emulator it will remember what serial ports is being used so the next time 
you start the RT Tuner program it will connect very quickly unless you move the emulator to a different 
port. 
 
If you want to cancel the search for the emulator, click on the ‘Cancel’ button and after a few seconds, 
the search will stop. 
 
If you don’t want the program to automatically connect the emulator each time you star the RT Tuner 
program, click on the ‘Options’ menu and uncheck the ‘Auto Connect’ option. If you disable the Auto 
Connect feature, then you will have to manually connect to the emulator when you want to work in real-
time mode. To manually connect to the emulator, select ‘Connect to Emulator’ from the ‘Tools’ menu or 

click on the Connect to Emulator button  in the main toolbar. 
 
Calibration Synchronization 
For the RT Tuner program to function properly in real-time mode, it is very important for the calibration 
currently in RT Tuner program to be synchronized with the calibration stored in the emulator. That is 
these calibrations must be identical. 
 
There are two ways to synchronize the two calibrations: 

1. You can load a calibration file into the RT Tuner program by selecting ‘Open’ from the ‘Files’ 
menu and then use this calibration to program the emulator. To program the emulator, you can 
either select ‘Program Emulator’ from the ‘Tools’ menu or you can click on the Program 

Emulator button   in the main toolbar. 
2. If you have a valid calibration already stored in the emulator, you can read the calibration in the 

emulator into the RT Tuner program by selecting ‘Read Eomulator’ from the ‘Tools’ menu or 

click on the Read Emulator button  in the main toolbar. 
 
Once the RT Tuner program and the emulator are synchronized, the RT Tuner program will 
automatically send any calibration changes you make to the emulator to maintain synchronization unless 
you’ve turned off (unchecked) the ‘Auto Update’ feature in the ‘Options’ menu. 
 
New Tools Menu 
The RT Tuner has a new ‘Tools’ menu containing three functions. Note: Do not perform any of these 
functions with the engine running. 
 

1. Connect to Emulator: Clicking this function will force  the RT Tuner program to connect to the 
Romulator. 

2. Read Emulator: Clicking on this selection with transfer the calibration stored in the emulator into 
the RT Tuner program. The RT Tuner program will check that the calibration stored in the 
emulator is valid and that you have selected the correct ECM Definition File. 

3. Program Emulator: This menu selection programs the emulator memory with the calibration that 
you currently have open in the RT Tuner program. If you don’t have a calibration open in the RT 
Tuner program, this function will be inactive. 
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New Toolbar Buttons 
Three new toolbar button have been added to the main program toolbar. These buttons are the Connect 

to Emulator button , the Read Emulator button , and the Program Emulator button . The 
buttons give you quick access to the corresponding functions in the ‘Tools’ menu as described above. 
 
New Options 
Three new options have been added to the options menu. 

1. Comm Port Setup: This option allows you to force the RT Tuner program to use the specified 
port as the first serial port on which to search for the emulator.   

2. Auto Update: Normally whenever you make a calibration change from the RT Tuner program, 
the program will immediately send the change to the emulator. If you need to multiple changes 
before sending the changes to the emulator, then you can uncheck this option and no changes 
will be sent until you update the emulator using the Program Emulator function. 

3. Auto Connect: When Auto Connect is enabled (checked), the RT Tuner program will attempt to 
connect to the emulator when you start the program. If you uncheck this option, the program will 
not auto connect and you will have to manually connect to the emulator when its needed. 

 
Status Bar 
The RT Tuner program has a new status bar at the bottom of the main screen. This status bar provides 
information about the status of the connection to the emulator.  
 

 
 

The status bar contains three sections.  
1. Calibration  Status: The calibration status section of the status bar is the section to the left and 

contain an indicator light and a description. This section describes the status of the calibration 
changes you have made from the RT Tuner program. There are four states that you may see. 

A. Synchronized – Green: This state indicates that the calibration information in the RT 
Tuner program and the emulator are the same. 

B. Not Synchrocnized – Red: This indicates that the RT Tuner and the emulator do not have 
the same calibration information. The RT Tuner will not send real-time updates to the 
emulator if the calibration information is not synchronized. 

C. Busy – Yellow: This state means that the RT Tuner program is in the process of sending 
changes to the emulator. As soon as the process is completed successfully, the status will 
return to Synchronized. 

D. Change Pending – Orange: This shows that you are in the process of making a calibration 
change that has not yet been sent to the emulator. 

2. General Messages: The center of the status bar gives you general messages regarding the 
emulator and the connection. When you first connect to the emulator, this section will show the 
emulator ID and the firmware version. 
3. Connection Status: Like the first, the third section contains an indicator light and a 

description area. This section shows the status of the connection to the emulator and has 
three states: 
A. Connected-Auto Update On – Green: This indicates that the RT Tuner program is 

connected to the emulator and the Auto Update function is enabled. 
B. Connected-Auto Update Off – Yellow: This indicates that the RT Tuner program is 

connected to the emulator but that the Auto Update function is disabled. 
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C. Not Connected – Red: This state will be displayed if the RT Tuner program is not 
connected to the emulator. 

 
Real-Time Calibration Changes 
Each time you ‘complete’ a calibration change from the RT Tuner program, the program automatically 
send the change to the emulator and the change takes effect as soon as the transfer is complete. 
 
When a calibration change is ‘completed’ depends on how you make the change from the Tuner 
program. In general if you are using the mouse to make changes such as by using the slider bar or the 
‘up/down’ arrows to adjust a constant, the change is complete as soon as you release the mouse button. 
Similarly, if your making a change by dragging a point on a graph, the change is not complete until you 
release the mouse button. 
 
If you are changing table values using the table cell edit, add, subtract, fill or scale functions, the change 
is complete when you click on the ‘OK’ button. 
 
One special case is when you are editing a constant by typing a new value directly into the constant 
value box. There are several things that complete this change so the program can send the new value to 
the emulator. The following events will complete this type of change: 

1. You press the ‘Enter’ key. 
2. You click on another constant in the Constants table. 

3. Your click on the ‘Update Emulator’ button  located in the top left hand corner of the 
Constants table screen. 

4. Click on another open table 
5. Close the Constants table.  

 
Until one of these events occurs the new value will not be sent to the emulator and the Calibration Status 
with show and orange light and say ‘Change Pending’. 
 


