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Introduction 
The C.A.T.S. RT Tuner program is a Windows based utility that allows you to easily make changes to 
GM ECM/PCM engine and transmission control parameters. The program is designed to run on 
Windows 98 or later operating systems. The program presents all the important tuning parameters in 
clear easy to understand tables that can be directly edited via keyboard and mouse commands.  
 
The C.A.T.S. RT Tuner was developed to allow ‘real-time’ ECM tuning when connected to the Xtronics 
(www.xtronics.com) Romulator (I and II) or the Craig Moates Ostrich or AutoProm (http://moates.net ) 
EPROM emulators. With the EPROM emulator replacing the ECM’s original EPROM, you can make 
calibration changes while the engine is running and the changes will take affect immediately. 
 
Note: For the RT Tuner program to be compatible, you must have firmware version 1.09 or later 
in your Romulator. If you have any earlier version, please contact Xtronics for information on 
updating your Romulator.  
 
The RT Tuner program functions exactly the same as our standard Tuner program, except that whenever 
you make a calibration change the RT Tuner program sends the change (or changes) to the Romulator. 
 
Note: The Romulator I only supports EPROMs up to 256K in size. If you select an ECM Definition File 
for a calibration that uses a larger EPROM, such as the $0D ECM Definition File, the program will 
immediately disconnect from the Romulator and revert to normal ‘off- line’ (non-real-time) operation 
and function just like the standard Tuner program.  The Romulator II supports EPROM’s up to 512K in 
size. The AutoProm supports EPROMs up to 512K in size. 
 
The Romulator and AutoProm emulators do not support the ‘94/95 LT1 FLASH based PCMs supported 
by the $EE ECM Definition File so real- time tuning is not possible on these cars. 
 
Minimum PC Requirements 
While the RT Tuner program will run on virtually any PC running Windows 98 or later, we recommend 
the following minimum PC specifications: 
 

Pentium 266 
Windows 98 
64 MB RAM 
600 x 800 display resolution 
20 MB free hard drive space 
1 serial port  

 
Program Installation 
To install the RT Tuner program, insert the OBDI Tuner CD into your CD ROM drive. The OBDI Tuner 
setup program should run automatically and the main setup screen will appear. 
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Click on the ‘Install OBDI RT Tuner Program’ selection to begin the installation. Then follow the on-
screen instructions to complete the installation. 
 
If the The OBDI RT Tuner setup program does not start automatically, navigate to your CD ROM drive 
and locate the file named ‘autorun.exe’ on the CD. Double click on this file to start the setup program. 
 
Note: If you are installng the OBDI Tuner program on a PC running Windows Vista or Windows 7 the 
installation process is a little different. Click on the ‘Vista Installation Instructions’ selection to view 
detailed instructions for installing the program under Vista / Windows 7. 
 
Registering the Program 
Once the program installation is complete you should have a icon on your desktop for the RT Tuner 
program. Double click on the icon to run the RT Tuner program. 
 
Note: At start-up the program will attempt to locate the emulator. If you do not have an emulator 
connected to your PC click on the ‘Cancel’ button to stop the search. 
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Select 'Register' from the 'Help' menu. 
  

 
 
  
When the registration form appears, enter your Customer ID and Serial Number into the appropriate 
boxes. Your registration information was included in the letter enclosed with your CD and can also be 
found on a label on the back of the CD case. 
 
Both the Customer ID and Serial Number are case sensitive and should be entered exactly as received. 
Enter your Customer ID and Serial Number carefully. Note that your Customer ID is all lower case and 
all the letters in your Serial Number are all upper case. 
 

 
. 
After entering your registration information click on the ‘Register’ button to complete the registration. If 
you entered the information correctly you will receive a message saying the registration was successful. 
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Click on the ‘OK’ button and the main OBDI Tuner screen will appear. 
 

 
 
 

Select the Desired ECM Definition Files 
To display a list of all the installed ECM Definition Files, click on the  ‘ECM’ menu on the main 
display.  
 

 
 
Select the appropriate ECM Definition File for the type of vehicle you will be tuning.from the drop-
down list.  
 
Loading a Calibration File  
A calibration file is a binary format file that is an image of the EPROM in the vehicle’s ECM/PCM and 
is usually created by reading the EPROM with an EPROM programmer. This file contains all the tuning 
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information that the ECM/PCM uses to control the vehicle. To load a calibration file into the RT Tuner 
program for viewing and editing click on the ‘Files’ menu and select ‘Open’ from the drop-down list or 
click on the Open File button on the toolbar. 
 

 
 
or 
 

 
 
Locate the desired file in the Open ECM Calibration File screen. Click on the file name to highlight it 
and then click on the ‘Open’ button to load the file into the RT Tuner program. 
 

 
 
The ‘Tables’ menu will now be active allowing you to select the calibration parameters you wish to 
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view and edit. 
 

 
 
 
Calibration Tuning 
 
You can view and edit the various calibration parameters. To view and edit these parameters click on the  
Tables  menu and then select the desired table from the drop-down list.  
 

 
 
This list will contain all the tables available for the selected ECM Definition File. When you select a 
table it will be displayed so you can view and edit the calibration values. 
 
The calibration parameters are grouped into three type of tables; a Switch Table, a Constant Table and 
2D and 3D tables. 
 
Switch Type Calibration Table 
The switch type calibration table will contain all the calibration items that can only have two values or 
states such as ‘on’ or ‘off’, or ‘Enabled’ or ‘Disabled’. This type of table will contain calibration items 
such as V.A.T.S. enabled/disabled.  
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Constant Type Calibration Table 
The Constant Table is used to present calibration values that represent single values or calibration 
constants such as the fuel cutoff RPM or injector flow rate. 
  

 
 
2D and 3D Calibration Tables 
The majority of the ECM Calibration Tables will be either 2D or 3D tables. These tables are used to 
display a series of values that depend on one (2D tables) or 2 other parameters (3D tables).  
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An example of a 2D table is the ‘Initial Startup AFR Enrichment Vs. Coolant Temp.’.  
 

 
A good example of a common 3D table would be the Main Spark Advance Vs. RPM Vs. MAP.  
 

 
 
 
Saving A Calibration File  
To save a calibration file after making changes select 'Save As' from the 'File' menu.  
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This will display the 'Save As' dialog box. Type in a file name for the calibration file in the ‘File name’ 
box and click the 'Save' button. 
  

 
 
To save the file using the same file name click on the ‘Files’ menu and select ‘Save’ from the drop-
down list or click on the Save File button in the toolbar. 
 
Real-Time Tuning 
 
Connecting the Emulator 

The first time you use the emulator with you ECM, you have to make a few minor modifications to 
your ECM to allow you to be able to connect the emulator to the ECM. 

 
1. Remove the ECM from the vehicle. 
2. Remove the access cover over the calibration chip or MEMCAL. 
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3. If your ECM is an older ECM with a calibration chip in a plastic PROM carrier: 
A. Remove the PROM carrier and calibration chip. 
B. Remove the circuit board from the metal housing 
C. Carefully unsolder and remove the special socket that the PROM carrier plugs into and 

replace it with a standard IC socket. Using a standard IC socket has the added benefit 
that you will no longer need the plastic PROM carrier (these part are obsolete and very 
difficult to find) so now you can just plug in a standard EPROM. Note: Make a note of 
pin 1 of the EPROM before removing the original socket to make sure you install 
the new socket correctly. 

D. Carefully remove the original EPROM from the PROM carrier and read it with your 
EPROM programmer. Save this file from the EPROM programmer software to your 
PC’s hard drive in binary format. This is the stock calibration file that you will use as 
your baseline calibration to which you’ll make the desired calibration modifications. 

E. Reinstall the circuit board into the metal housing. 
4. If your ECM is a newer ECM with a MEMCAL: 

A. Remove the MEMCAL from the ECM 
B. Carefully unsnap the cover from the MEMCAL (its usually blue or brown). 
C. Carefully unsolder the EPROM that’s now accessible from the MEMCAL. Note: 

Make a note of the orientation of the EPROM before removing it. 
D. Solder a standard IC socket in place of the original EPROM noting the correct 

orientation. 
E. Reinstall the MEMCAL in the ECM. 
F. Read the EPROM that you removed with your EPROM programmer. Save this file 

from the EPROM programmer software to your PC’s hard drive in binary format. This 
is the stock calibration file that you will use as your baseline calibration to which you’ll 
make the desired calibration modifications. 

 
Note: If you’d rather not modify the original MEMCAL there are a variety of MEMCAL 
adapter available from suppliers like Craig Moates (www.moates.net) that provide a socket 
for connecting the emulator without modifying the MEMCAL. 

 
You’ve now completed the necessary modifications to your ECM that you only need to do once and 
can connect the emulator to your ECM. Note: Make sure the vehicles ignition is OFF during 
these next steps. 
 

1. Plug the emulator connector into the socket that you’ve just installed in your ECM noting 
the proper orientation (pin 1 if the connector is at the end with the red stripe on the emulator 
cable). 

2. Reconnect the ECM to the vehicle. 
3. Connect the serial cable to the emulator and to an available serial port on your PC.  
4. Run the RT Tuner program and wait for the program to connect to the emulator. 
5. Load the calibration file that you created by reading the original EPROM from the ECM 

above into the RT Tuner program by selecting ‘Open’ from the ‘Files’ menu (or clicking on 

the Open File button  on the toolbar. Select the calibration file that you created and 
click on ‘Open’. 
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6. Now program this calibration into the emulator. To program the emulator, you can either 
select ‘Program Romulator’ from the ‘Tools’ menu or you can click on the Program 

Romulator button   in the main toolbar. 
 

You’re now ready to start real-time tuning. Start the engine and start tuning. Any calibration 
changes you make from the RT Tuner program will be sent immediately to the emulator so you can 
see the effect of your changes in real time. 

 
Program Startup 

When you start the RT Tuner program, the program will automatically attempt to connect to the 
emulator by searching all available serial ports. The first time you run the RT Tuner program, this 
may take a little while. 
 
Once the program finds the emulator it will remember what serial ports is being used so the next 
time you start the RT Tuner program it will connect very quickly unless you move the emulator to a 
different port. 
 
If you want to cancel the search for the emulator, click on the ‘Cancel’ button and after a few 
seconds, the search will stop. 
 
If you don’t want the program to automatically connect the emulator each time you star the RT 
Tuner program, click on the ‘Options’ menu and uncheck the ‘Auto Connect’ option. If you disable 
the Auto Connect feature, then you will have to manually connect to the emulator when you want to 
work in real-time mode. To manually connect to the emulator, select ‘Connect to Romulator’ from 

the ‘Tools’ menu or click on the Connect to Romulator button  in the main toolbar. 
 
Calibration Synchronization 

For the RT Tuner program to function properly in real-time mode, it is very important for the 
calibration currently in RT Tuner program to be synchronized with the calibration stored in the 
emulator. That is these calibrations must be identical. 
 
There are two ways to synchronize the two calibrations: 

1. You can load a calibration file into the RT Tuner program by selecting ‘Open’ from the 
‘Files’ menu and then use this calibration to program the emulator. To program the 
emulator, you can either select ‘Program Romulator’ from the ‘Tools’ menu or you can 

click on the Program Romulator button  in the main toolbar. 
2. If you have a valid calibration already stored in the emulator, you can read the calibration in 

the Romulator into the RT Tuner program by selecting ‘Read Romulator’ from the ‘Tools’ 

menu or click on the Read Romulator button  in the main toolbar. 
 

Once the RT Tuner program and the emulator are synchronized, the RT Tuner program will 
automatically send any calibration changes you make to the emulator to maintain synchronization 
unless you’ve turned off (unchecked) the ‘Auto Update’ feature in the ‘Options’ menu. 
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RT Tuner Tools Menu 
The RT Tuner has a ‘Tools’ menu containing three functions. Note: Do not perform any of these 
functions with the engine running. 

 
1. Connect to Romulator: Clicking this function will force the RT Tuner program to connect 

to the emulator. 
2. Read Romulator: Clicking on this selection with transfer the calibration stored in the 

emulator into the RT Tuner program. The RT Tuner program will check that the calibration 
stored in the emulator is valid and that you have selected the correct ECM Definition File. 

3. Program Romulator: This menu selection programs the emulator memory with the 
calibration that you currently have open in the RT Tuner program. If you don’t have a 
calibration open in the RT Tuner program, this function will be inactive. 

 
RT Tuning Toolbar Buttons 

There are hree toolbar buttons in the main program toolbar associated with real- time tuning. These 

buttons are the Connect to Romulator button , the Read Romulator button , and the Program 

Romulator button . The buttons give you quick access to the corresponding functions in the 
‘Tools’ menu as described above. 

 
Program Options 

Three real-time tuning options are located in the ‘Options’ menu. 
1. Comm Port Setup: This option allows you to force the RT Tuner program to use the 

specified port as the first serial port on which to search for the emulator.   
2. Auto Update: Normally whenever you make a calibration change from the RT Tuner 

program, the program will immediately send the change to the emulator. If you need to 
multiple changes before sending the changes to the emulator, then you can uncheck this 
option and no changes will be sent until you update the emulator using the Program 
emulator function. 

3. Auto Connect: When Auto Connect is enabled (checked), the RT Tuner program will 
attempt to connect to the emulator when you start the program. If you uncheck this option, 
the program will not auto connect and you will have to manually connect to the emulator 
when its needed. 

 
Status Bar 

The RT Tuner program has a new status bar at the bottom of the main screen. This status bar 
provides information about the status of the connection to the emulator.  
 

 
 
The status bar contains three sections.  

1. Calibration Status: The calibration status section of the status bar is the section to the left 
and contains an indicator light and a description. This section describes the status of the 
calibration changes you have made from the RT Tuner program. There are four states that 
you may see. 
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A. Synchronized – Green: This state indicates that the calibration information in the RT 
Tuner program and the emulator are the same. 

B. Not Synchronized – Red: This indicates that the RT Tuner and the emulator do not 
have the same calibration information. The RT Tuner will not send real-time updates to 
the emulator if the calibration information is not synchronized. 

C. Busy – Yellow: This state means that the RT Tuner program is in the process of 
sending changes to the emulator. As soon as the process is completed successfully, the 
status will return to Synchronized. 

D. Change Pending – Orange: This shows that you are in the process of making a 
calibration change that has not yet been sent to the emulator. 

2. General Messages: The center of the status bar gives you general messages regarding the 
emulator and the connection. When you first connect to the emulator, this section will show 
the emulator ID and the firmware version. 

3. Connection Status: Like the first, the third section contains an indicator light and a 
description area. This section shows the status of the connection to the emulator and has 
three states: 
A. Connected-Auto Update On – Green: This indicates that the RT Tuner program is 

connected to the emulator and the Auto Update function is enabled. 
B. Connected-Auto Update Off – Yellow: This indicates that the RT Tuner program is 

connected to the emulator but that the Auto Update function is disabled. 
C. Not Connected – Red: This state will be displayed if the RT Tuner program is not 

connected to the emulator. 
 
Real-Time Calibration Changes 

Each time you ‘complete’ a calibration change from the RT Tuner program, the program 
automatically send the change to the emulator and the change takes effect as soon as the transfer is 
complete. 
 
When a calibration change is ‘completed’ depends on how you make the change from the Tuner 
program. In general if you are using the mouse to make changes such as by using the slider bar or 
the ‘up/down’ arrows to adjust a constant, the change is complete as soon as you release the mouse 
button. Similarly, if your making a change by dragging a point on a graph, the change is not 
complete until you release the mouse button. 
 
If you are changing table values using the table cell edit, add, subtract, fill or scale functions, the 
change is complete when you click on the ‘OK’ button. 
 
One special case is when you are editing a constant by typing a new value directly into the constant 
value box. There are several things that complete this change so the program can send the new 
value to the emulator. The following events will complete this type of change: 
 

1. You press the ‘Enter’ key. 
2. You click on another constant in the Constants table. 

3. Your click on the ‘Update Romulator’ button  located in the top left hand corner of the 
Constants table screen. 

4. Click on another open table 
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5. Close the Constants table.  
 

Until one of these events occurs the new value will not be sent to the emulator and the Calibration 
Status with show and orange light and say ‘Change Pending’. 

 
Tuning 1994/1995 LT1 Cars 
 
These cars used a new design PCM that no longer used an EPROM to store the calibration information. 
This PCM used Flash memory that is read and programmed through the ALDL diagnostic connector 
located under the car’s dashboard. 
 
While this eliminates the need to remove and reprogram an EPROM when tuning there is no way to 
connect an emulator since there is no longer an EPROM that can be removed which means that you can 
not do real-time tuning on these cars. 
 
You can still use the RT Tuner to tune these cars but the real-time functions are not available. 
 
To read and program the PCM used in these cars you connect you PC to the car’s ALDL connector 
using an ALDL interface cable like our USB/ALDL Interface Cables. 
 
ECM Installing the USB/ALDL Interface Cable Drivers 
Before using one of our USB/ALDL Interface cable you must install the software drivers. To install 
these drivers insert the OBDI Tuner CD into your CD ROM drive. The OBDI Tuner setup program 
should run automatically and the main setup screen will appear. 
 
Click on the ‘USB/ALDL Cable Driver Instructions’ selection to view detailed instructions for installing 
these drivers. 
 
Com Port Selection 
When the USB/ALDL Interface Cable drivers are installed, start the Tuner program again, click on the 
‘Options’ menu and select ‘Comm Port Setup’ from the drop-down list. 
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This will display a list of com ports one through 8 and the status of each com port. 
 

 
 
Select the com port that was assigned to your USB/ALDL Interface cable when you installed the drivers  
and then click 'OK'. The program will save this selection so you don't have to set the com port again 
unless you change to a different port.  
 
Reading the PCM 
To begin tuning you must read the current calibration information from the car’s PCM and load it into 
the Tuner program. 
 
To read the calibration currently stored in the PCM, select 'Read PCM' from the 'Tools' menu.  
 

 
 
This will display the read PCM start screen. 
  

 
 
Before proceeding, connect your USB/ALDL Interface cable to your PC and to the car’s ALDL 
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connector under the dashboard.  
 
Once the cable is connected, turn the ignition key on but DO NOT start the engine. After turning on the 
ignition, wait about 10 to 15 seconds to clear the GM security delay before proceeding.  
 
Now click on 'OK' to begin the read process. If all the connections have been properly made, the 
program will begin communicating with the PCM, sending the necessary instructions to start the 
memory read process.   
 
The following status window will be displayed during the read process: 

 
 
The progress meter shows the progress on the reading of the PCM as it proceeds and the Status window 
describes what part of the process in currently underway. Depending on the PC you are using, the 
programming will usually take about five minutes 
 
When the read process is complete, the message shown below will be displayed: 
  

 
 
Click 'OK' to complete the PCM read and close the message box. You can now disconnect the 
USB/ALDL Interface cable from the car and turn off the ignition. 
 
The calibration from your PCM will now be loaded into the Tuner program and you can now view and 
edit the calibration parameters as needed.  
 
Note: its always a good idea to save a copy of the original calibration just in case you ever want to go 
back to the stock calibration. 
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Rev B Calibrations 
A small number of the early 1994 cars had an early version of the calibrations refered to as the Rev B 
calibration. If your car has a Rev B calibration you will need to use the $EEB ECM Definition File 
instead of the standard $EE ECM Definition File. 
 
To check whether you are working with a Rev B calibration or not, open the 'Constant Table' as 
described above and look at the values for the Cylinder Volume and Injector Flow Rate parameters. If  
these values look reasonable, then you are working with a standard $EE ECM Definition File. If you are 
in fact working with a Rev B calibration, then the values for these parameters will be very strange; the 
Cylinder Volume is typically 0 and the Injector Flow Rate will be a ridiculously large value like 793.46 
lbs/hr. 
 
If you are working with a Rev B calibration click on the ‘ECM’ menu and select ‘PCM_EEB’ from the 
drop-down list. Then go back an read the PCM again to properly load you calibration into the Tuner 
program. 
 
Programming the PCM 
Once you are finished tuning you need to load your modified calibration into the car’s PCM by 
programming the PCM with the modified calibration. Before beginning the programming process you 
should save a copy of you modified calibration in case you need to make adiitional changes.   
 

WARNING  
 

If the programming process does not complete successfully it is possible to damage the 
PCM. Under no circumstances should you interrupt the programming process once it is 

started. 
 
The following are recommendations for the successful programming of your PCM:  

?? Before programming the PCM, make sure you can successfully read the PCM. This is a very 
similar process and if that is successful, then the programming should also work fine. YOU CAN 
NOT DAMAGE YOUR PCM BY READING IT.  

?? Make sure the car battery is in good condition and fully charged. DO NOT try to program the 
PCM with a battery charger connected to the car battery. The correct range of the battery voltage 
for PCM programming is relatively narrow.  

?? If you're using a laptop, make sure the laptop battery is fully charged.  
?? Make sure you have good connections between the PC, ALDL connector and the interface cable 

and that they are not likely to be unintentionally disconnected during the programming process.  
?? Disable all power management functions on your PC.  
?? Disable all screen savers on the PC.  
?? Make sure there are no other applications (programs) running on your PC, including virus 

checkers.  
 
To program your modified calibration into the PCM, select 'Program PCM' from the 'Tools' menu.  
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This will display the Program PCM start screen. 
  

 
 
Before proceeding, connect the USB/ALDL Interface cable to your PC. Connect the other end of the 
converter to the ALDL diagnostics connector in the car.  
 
Once the cable is connected, turn the ignition key on but DO NOT start the engine. After turning on the 
ignition, wait about 10 to 15 seconds to clear the GM security delay before proceeding with 
programming.  
Now click on 'OK' to begin the PCM programming process. If all the connections have been properly 
made, the program will begin communicating with the PCM, sending the necessary instructions to start 
the memory programming process.  The following status window will be displayed during the read 
process: 
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The progress meter shows the progress on the programming as it proceeds and the Status window 
describes what part of the process in currently underway. Depending on the PC you are using, the 
programming will usually take about five minutes.  
 
When the FLASH programming process is complete, the message shown below will be displayed: 
  

 
 
Click 'OK' to complete the PCM programming and close the message box. 
 
Your modified calibration has now been transferred to the PCM and is ready for testing. 
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